Summary: When assigning Office 365 licenses you may encounter errors in Cayosoft automation rules and actions. These errors occur due to different dependencies between licenses:
- Office 365 licenses may conflict with each other because they contain the same service plans but these service plans have different ranks (for example, SharePoint Online (Plan 2) and SharePoint Online (Plan 1)).
- Office 365 licenses can have service plans that depend on other service plans and can be assigned only together.
- Office 365 licenses can be treated as add-ons towards the other service plans. The add-on license cannot be assigned to the user without a corresponding service plans being assigned.
If Office 365 licenses have dependent service plans, these dependencies require Cayosoft Administrator to revoke and assign licenses in a specific order.
To avoid the errors during license assignment, you should configure special settings in Microsoft Office 365 Extension, in Admin Console.
This article provides step-by-step troubleshooting procedures to resolve each type of error.
Applies to: Cayosoft Administrator 6.1.1 or later
ID: KB20191011-1
Typical error messages
Issues in Cayo Admin Service | Issues in MS Admin Center | Resolution |
---|---|---|
Office 365 license has conflicting services |
|
|
Unable to update license for this user. The set of licenses includes two or more service plans which cannot be assigned at the same time. Conflicting Service Plans: EXCHANGE_S_STANDARD, EXCHANGE_S_ENTERPRISE. |
You can't assign licenses that contain these conflicting services: Exchange Online (Plan 2), Exchange Online (Plan 1). Review the services included with each license, and try again. |
|
Office 365 license has dependent service plans or Office 365 license that is treated as an add-on |
|
|
1. Unable to assign this license because it is invalid. Use the Get-MsolAccountSku cmdlet to retrieve a list of valid licenses. 2. Unable to assign this license.
|
1. To assign a license that contains Office for the web, you must also assign one of the following service plans: SharePoint Online (Plan 2), SharePoint Online (Plan 1).To assign a license that contains Project Online Service, you must also assign one of the following service plans: SharePoint Online (Plan 2). 2. To assign a license that contains Audio Conferencing, you must also assign one of the following service plans: Microsoft Teams, Skype for Business Online (Plan 2).
|
1. Microsoft Office 365 licenses have conflicting services
Root cause
Office 365 licenses may conflict with each other because they contain the same service plans but these service plans have different ranks (for example, SharePoint Online (Plan 2) and SharePoint Online (Plan 1)).
Requirement
If you need to assign Office 365 licenses that have the same service plans but these service plans have different ranks simultaneously, you should specify these licenses in the Enforce License Precedence setting in Microsoft Office 365 extension, Advanced Settings section.
How to resolve
- In Cayosoft Admin Console navigate to Extensions > Microsoft Office 365, Advanced Settings section.
- In Enforce license precedence setting specify the IDs of the conflicting service plans. These IDs are displayed in the Cayosoft Admin Service error.
Example:
Exchange Online (Plan 2), Exchange Online (Plan 1) are conflicting service plans. You should specify them in Enforce license precedence setting like his: SHAREPOINTSTANDARD>SHAREPOINTENTERPRISE.
For more details, please see How to enforce license precedence article.
2. Microsoft Office 365 licenses have dependent services
Root cause
Office 365 licenses can have service plans that depend on other service plans and can be assigned only together.
Or
Office 365 licenses can be treated as add-ons towards the other service plans. The add-on license cannot be assigned to the user without a corresponding service plans being assigned.
Requirement
To define service plan dependencies, you should specify License Add-ins Services IDs setting in Microsoft Office 365 extension, Advanced Settings section. License Add-ins Services IDs setting should contain the ID of the Office 365 license that has dependent service plans.
How to resolve
- Login to Office 365 Admin Center https://admin.microsoft.com
- Perform exactly the same license change operations that you perform in Cayosoft Administrator.
- Use information from the error message to define service plan dependencies.
- In Cayosoft Admin Console navigate to Extensions > Microsoft Office 365, Advanced Settings section.
- In License Add-ins Services IDs setting specify the ID of the Office 365 license that has dependent service plans.
- To get the ID of Office 365 license, open the license cache file that is specified in License Cache File setting.
- Find the license name and copy the corresponding ID.
- Save changes.
Example
The user account have two plans assigned: Office 365 (Plan E3) (ENTERPRISEPACK) and Dynamics 365 Customer Engagement Plan (DYN365_ENTERPRISE_PLAN1).
Comments
0 comments
Please sign in to leave a comment.