Symptom
After a recent upgrade to Cayosoft Administrator v12.1 or later, the console prompts the following error:
The Entra ID application registration for Cayosoft Administrator was not found. Navigate to the Microsoft 365 extension settings and click Find or register the app.
Cause
Starting v12.1, Cayosoft Administrator explicitly registers the API app for the Microsoft 365 connection account. Cayosoft Administrator reads and copies the application ID of the API app assigned to the user. If no API app is found, the app is generated and assigned to the connection account. Once assigned and associated, the Application ID value is added to the Entra ID application ID field in the Microsoft 365 extension settings.
Resolution
Refer to the following steps to resolve the issue:
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In the left pane of Cayosoft Administrator, navigate to Configuration > Settings > Connected Systems > Extensions > Microsoft 365.
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Click the Find or register the app button to associate the existing API app or register a new app, if needed. Proceed with the login prompts to complete the process.
NOTE: Depending on the previously granted permissions, you might encounter the Consent is not granted message. For additional information on the message and the upgrade process, refer to the following article: Upgrade Cayosoft Administrator from earlier version—Consent not granted.
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