Troubleshooting Cayosoft Administrator Active Directory DC Connection Issues
Summary
During installation and initial configuration, Cayosoft Administrator performs various pre- installation checks to ensure all required components are installed and system settings are configured properly. However, there is the possibility that some settings may have been updated after the Cayosoft Administrator installation, or some settings were not properly verified during installation. This article provides a set of verification procedures to ensure the system where the Cayosoft Administrator Service is installed is configured properly.
Typical error messages
Error: Could not find an available Domain Controler.
Error: Account specified for Active Directory extension expired or credentials failed, immediate action required.
Error: Unable to contact Global Catalog server. This may be because this server doesn't exist, it is currently down, or it doesn't have the Active Directory Web Services running.
Error: Unable to contact the server. This may be because this server doesn't exist, it is currently down, or it doesn't have the Active Directory Web Services running.
Symptom 1
Cayosoft fails to connect to Active Directory when the user attempts to configure a domain controller and may present an error dialog.
Cause
The most likely cause is that the target domain controller is not running Windows Remote Management.
Resolution
Enable Windows PowerShell Remoting on the server specified in the error. If the Global Catalog is specified in the error, you need to verify the Windows Remote Management on the Global Catalog server. If some other Domain Controller then verify Windows Remote Management on it.
-
On the server specified in the error, verify the Windows Remote Management (WS- Management) is set to start automatically and is started.
Go to Task Manager > Services and locate the WinRM service, verify the Status is Running. If the service is not running, open the Services console, right-click the WinRM service and choose properties - then set the Startup Type to Automatic.
Enable the PowerShell Remoting with the Enable-PSRemoting command.
Symptom 2
Cayosoft fails to connect to Active Directory when the user clicks Check Settings on the Active Directory extension.
Cause
The Active Directory Global Admin account is not valid.
Resolution
-
Check that Active Directory Global Admin account:
Specified with correct credentials.
Is not locked.
Is not expired.
Password is not expired.
Cause
Domain Controller is unavailable for some reason.
Resolution
Check that specified Domain Controller is available:
Ping this DC from the machine where the Cayosoft Administrator Service is running.
Run a new CMD shell.
Type
ping <DC.domain.com>
Cause
Active Directory Web Service is not running on Domain Controller specified for domain in Managed Domains table or in Forest settings in Home > Configuration > Connected Systems Extensions > Active Directory.
To get DC specified as GC for a forest you need to click the Configure... link on forest header.
Resolution
Check that the Active Directory Web Service is running on the Domain Controller:
Login to the Domain Controller specified for a domain/forest.
Run the Services snap-in.
Find the Active Directory Web Services service.
Start the Active Directory Web Services if it is not running.
Cause
The Cayosoft Administrator Service is blocked by the firewall.
Resolution
Check that required ports are opened. For more information, please see the Cayosoft Administrator URLs and IP address ranges article.
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